Knowledgebase
* Installing ARES Commander on Ubuntu x64 (deb-package)
Posted by Christian Kramer on 2019-06-11 07:49

Note: Since ARES Commander 2015 we ship only 64-bit Linux versions! This article below is only valid for older versions.

For Ubuntu x64 14.04 LTS

The following steps

$sudo bash

After getting a

#dpkg --add-architecture i386 && apt-get update
#apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0
#libuuid1:i386 libice6:i386 libsm6:i386 libxt6:i386 libaudio2:i386 libgtk2.0-0:i386 libcanberra-gtk-module:i386 libcanberra-gtk0:i386 libglu1-mesa:i386

 

For Ubuntu x64 (10.04 and 9.10)

There are some problems in installing and executing 32-bit applications on a 64-bit Linux, mainly caused by different run-time libraries and the resulting dependencies. Depending on the used distribution there are different ways to handle this problem.

The following workaround should help to get ARES running on a 64-bit Linux. It was tested on Ubuntu x64 9.10 and 10.04, but should work for the most Debian based Linux distributions too.
Here you find an article in the Ubuntu forum, which describes the solution.

Please note, we don’t warrant the correct work of the following instructions. Also we can not exclude any resulting side effects or problems to your system after applying the workaround described below. Hence, you apply these installation on your own risk!

This solution is not working with a LiveCD. An installed Ubuntu is required.

To satisfy the necessary dependencies you must first install and manage the related 32-bit libraries. Fortunately a shell script exists, which will execute this task for you. So please download this script from here. Then open/install this downloaded package by double-clicking it in the file manager.

The following steps must be applied as root, so simply get root first:

[email protected]$ sudo bash

Apply the installed shell script getlibs to the downloaded ARES package:
(In this line adapt the path and package file name to your own needs, please):

[email protected]# getlibs -i /home/user1/downloads/graebert-ares-commander-edition-20xx.xx.xxx.deb

This script installs the package ia32-libs first, then it checks the package for additional necessary 32-bit libraries, which are automatically installed, if possible.

Finally you must force to install ARES:

[email protected]# dpkg -i --force-all graebert-ares-commander-edition-20xx.xx.xxx.deb

Now you should be able to start ARES.